Interchange < 5.2.1 Multiple Injection Vulnerabilities

High Nessus Network Monitor Plugin ID 3241

Synopsis

The remote web server contains a script that is vulnerable to a SQL injection attack.

Description

The remote host is running Interchange, a web-based content management application. This version of Interchange is vulnerable to a flaw in the way that it handles malformed data. An attacker exploiting these flaws would be able to inject commands into SQL statements or inject executable code that would be executed by the web server process.

Solution

Upgrade to version 5.2.1 or higher.

Plugin Details

Severity: High

ID: 3241

File Name: 3241.prm

Family: CGI

Published: 2005/09/26

Modified: 2016/01/15

Dependencies: 1442

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

CVSSv3

Base Score: 7.3

Temporal Score: 7

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:H/RL:O/RC:C

Reference Information

CVE: CVE-2005-3072, CVE-2005-3073

BID: 14931