vBulletin < 3.0.10 Multiple Vulnerabilities

High Nessus Network Monitor Plugin ID 3231

Synopsis

The remote host is vulnerable to multiple attack vectors.

Description

The version of vBulletin installed on the remote host fails to properly sanitize user-supplied input to a number of parameters and scripts before using it in database queries and to generate dynamic HTML. An attacker can exploit these issues to launch SQL injection and cross-site scripting attacks against the affected application. Note that the affected scripts require moderator or administrator acess, with the exception of 'joinrequests.php'.

Solution

Upgrade to version 3.0.10 or higher.

See Also

http://morph3us.org/advisories/20050917-vbulletin-3.0.8.txt

Plugin Details

Severity: High

ID: 3231

File Name: 3231.prm

Family: CGI

Published: 2005/09/19

Modified: 2016/02/05

Dependencies: 1442

Nessus ID: 19760

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:H/RL:OF/RC:ND

CVSSv3

Base Score: 7.3

Temporal Score: 6.9

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:H/RL:O/RC:X

Reference Information

CVE: CVE-2005-3020, CVE-2005-3019, CVE-2005-3024, CVE-2005-3025

BID: 14872, 14874, 15296

OSVDB: 19534, 19535, 19536, 19537, 19538, 19539, 19540, 19541, 19542, 19543