punBB < 1.2.7 Multiple SQL Injection Vulnerabilities

High Nessus Network Monitor Plugin ID 3220

Synopsis

The remote web server contains a script that is vulnerable to a SQL injection attack.

Description

The remote host is running punBB, a web-based bulletin board. This version of punBB is vulnerable to a SQL Injection attack. Due to a content-parsing flaw, attackers can inject SQL commands into a PHP script. An attacker exploiting this flaw would only need to be able to send HTTP requests to the application. Successful exploitation would result in the attacker having the ability to read or write to the database. In addition, the attacker may be able to execute arbitrary commands on the remote system.

Solution

Upgrade to version 1.2.7 or higher.

Plugin Details

Severity: High

ID: 3220

Family: CGI

Published: 2005/09/12

Modified: 2016/01/15

Dependencies: 1442

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

CVSSv3

Base Score: 7.3

Temporal Score: 7

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:H/RL:O/RC:C

Reference Information

CVE: CVE-2005-4665

BID: 14808, 14806