OpenSSH < 4.2p1 GSSAPI Authentication Credential Escalation

Low Nessus Network Monitor Plugin ID 3205

Synopsis

The remote host is vulnerable to a flaw that allows attackers to retrieve sensitive files or data.

Description

The remote host is running a version of OpenSSH which is vulnerable to a flaw in the way that it handles GSSAPI authentication. Specifically, if GSSAPI is enabled and 'GSSAPIDelegateCredentials' is enabled, an attacker may gain access to GSSAPI credentials.

Note: PVS has solely relied on the banner of the SSH client to perform this check. Any backported patches or workarounds such as recompiling or edited configurations are not observable through the banner.

Solution

Upgrade to version 4.2p1 or higher.

Plugin Details

Severity: Low

ID: 3205

File Name: 3205.prm

Family: SSH

Published: 2005/09/06

Modified: 2016/11/23

Dependencies: 3210, 3211

Risk Information

Risk Factor: Low

CVSSv2

Base Score: 3.3

Temporal Score: 2.9

Vector: CVSS2#AV:A/AC:L/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

CVSSv3

Base Score: 4.2

Temporal Score: 4

Vector: CVSS3#AV:A/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

Temporal Vector: CVSS3#E:H/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:openbsd:openssh

Reference Information

CVE: CVE-2005-2798

BID: 14729

OSVDB: 19141