YaPiG EXIF Data Script Injection

Low Nessus Network Monitor Plugin ID 3186

Synopsis

The remote host is vulnerable to a script injection attack.

Description

The remote host is running YaPiG, a web-based image gallery written in PHP. According to its banner, the version of YaPiG installed on the remote host is prone to script insertion attacks because it does not sanitize malicious EXIF data stored in image files. Using a specially-crafted image file, an attacker can exploit this flaw to cause arbitrary HTML and script code to be executed in a user's browser within the context of the affected application.

Solution

Upgrade or patch according to vendor recommendations.

See Also

http://www.seclab.tuwien.ac.at/advisories/TUVSA-0510-001.txt

http://archives.neohapsis.com/archives/bugtraq/2006-08/0483.html

http://cedri.cc/advisories/EXIF_XSS.txt

Plugin Details

Severity: Low

ID: 3186

File Name: 3186.prm

Family: CGI

Published: 2005/08/26

Modified: 2016/02/05

Dependencies: 1442

Nessus ID: 19515

Risk Information

Risk Factor: Low

CVSSv2

Base Score: 3.3

Temporal Score: 3.1

Vector: CVSS2#AV:A/AC:L/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:F/RL:U/RC:ND

CVSSv3

Base Score: 4.2

Temporal Score: 4.1

Vector: CVSS3#AV:A/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

Temporal Vector: CVSS3#E:F/RL:U/RC:X

Reference Information

CVE: CVE-2005-2736, CVE-2005-4799, CVE-2006-4421

BID: 19709, 15092, 15095, 23814, 14670