Discuz File Extension Validation Weakness Arbitrary File Upload

Medium Nessus Network Monitor Plugin ID 3167

Synopsis

The remote host is vulnerable to a script injection attack.

Description

The remote host is running Discuz, a web-based message board. This version of Discuz is vulnerable to a flaw that would allow remote attackers to upload arbitrary files to the web server. The attacker could then execute the uploaded file (with the permission of the web server) or convince other Discuz users to download and/or execute the code. An attacker exploiting this flaw would be able to gain access to confidential data, potentially impact the availability of the server, and tarnish the integrity of the server.

Solution

No solution is known at this time.

Plugin Details

Severity: Medium

ID: 3167

File Name: 3167.prm

Family: CGI

Published: 2005/08/17

Modified: 2016/02/05

Dependencies: 1442

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 6.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:U/RC:ND

CVSSv3

Base Score: 6.2

Temporal Score: 5.6

Vector: CVSS3#AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:U/RL:U/RC:X

Reference Information

CVE: CVE-2005-2614

BID: 14564