WordPress < 1.5.1.4 RCE

Medium Nessus Network Monitor Plugin ID 3162

Synopsis

The remote server is hosting an outdated installation of WordPress that is vulnerable to a script injection attack.

Description

Versions of WordPress prior to 1.5.1.4 will accept and execute arbitrary PHP code passed to the 'cache_lastpostdate' parameter via cookies provided PHP's 'register_globals' setting is enabled.

Solution

Upgrade to version 1.5.1.4 or disable PHP's 'register_globals' setting.

See Also

http://www.nessus.org/u?2c5481e5

Plugin Details

Severity: Medium

ID: 3162

Family: CGI

Published: 2005/08/10

Modified: 2016/11/23

Dependencies: 9035

Nessus ID: 19414

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 6.8

Temporal Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:H/RL:U/RC:ND

CVSSv3

Base Score: 5.6

Temporal Score: 5.6

Vector: CVSS3#AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:H/RL:U/RC:X

Exploitable With

Metasploit (WordPress cache_lastpostdate Arbitrary Code Execution)

Reference Information

CVE: CVE-2005-2612

BID: 14533