Moodle < 1.5.1 Unspecified Vulnerability

High Nessus Network Monitor Plugin ID 3063

Synopsis

The remote host is vulnerable to unspecified remote attack vectors.

Description

Moodle is an open source web-based course management platform written in PHP. Versions of Moodle prior to 1.5.1 are missing patches to multiple undisclosed flaws that may affect the confidentiality or integrity of the remote host.

Solution

Upgrade to Moodle 1.5.1 or higher.

Plugin Details

Severity: High

ID: 3063

Family: CGI

Published: 2005/07/12

Modified: 2016/11/23

Dependencies: 8683

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSSv3

Base Score: 7.3

Temporal Score: 6.4

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:moodle:moodle

Patch Publication Date: 2005/07/08

Vulnerability Publication Date: 2005/07/08

Reference Information

CVE: CVE-2005-2247

BID: 14224