PHPNews < 1.2.6 news.php prevnext Parameter SQL Injection

High Nessus Network Monitor Plugin ID 3047

Synopsis

The remote host is vulnerable to a SQL Injection attack.

Description

The remote host is running PHPNews, an open-source news application written in PHP. The installed version of PHPNews is prone to a SQL injection attack due to its failure to sanitize user-supplied input via the 'prevnext' parameter of the 'news.php' script. An attacker can exploit this flaw to affect database queries, possibly revealing sensitive information, launching attacks against the underlying database, and more.

Solution

Upgrade to version 1.2.6 or higher.

See Also

http://newsphp.sourceforge.net/changelog/changelog_1.26.txt

Plugin Details

Severity: High

ID: 3047

File Name: 3047.prm

Family: CGI

Published: 2005/07/05

Modified: 2016/01/15

Dependencies: 1442

Nessus ID: 18621

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

CVSSv3

Base Score: 7.3

Temporal Score: 7

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:H/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:phpnews:phpnews

Reference Information

CVE: CVE-2005-2156

BID: 14133