phpBB < 2.0.16 viewtopic.php Arbitrary Code Execution

Medium Nessus Network Monitor Plugin ID 3038

Synopsis

The remote host is vulnerable to a Script Injection attack.

Description

The remote host is running phpBB, a web-based forum application written in PHP. There is a flaw in this version of phpBB that will allow remote attackers to inject arbitrary code into the 'viewtopic.php' script. An attacker exploiting this flaw would only need to be able to send an HTTP request to the vulnerable script. Successful execution would result in the attacker executing code with the permissions of the webserver.

Solution

Upgrade to version 2.0.16 or higher.

See Also

http://www.securityfocus.com/archive/1/403631/30/0/threaded

Plugin Details

Severity: Medium

ID: 3038

File Name: 3038.prm

Family: CGI

Published: 2005/06/29

Modified: 2016/02/05

Dependencies: 1442

Nessus ID: 18589

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 4.6

Temporal Score: 3.8

Vector: CVSS2#AV:L/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 5.9

Temporal Score: 5.4

Vector: CVSS3#AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:phpbb_group:phpbb

Exploitable With

CANVAS (CANVAS)

Metasploit (phpBB viewtopic.php Arbitrary Code Execution)

Reference Information

CVE: CVE-2005-2086

BID: 14086

OSVDB: 17613