Ultimate PHP Board < 1.9.7 Multiple XSS

Medium Nessus Network Monitor Plugin ID 3017

Synopsis

The remote host has a PHP script that may allow arbitrary code execution on the remote system

Description

The remote host is running Ultimate PHP Board, a message board written in PHP. Versions of Ultimate less than 1.9.7 are vulnerable to multiple Cross-Site Scripting (XSS) flaws. An attacker exploiting these flaws would typically need to be able to convince a user to browse to a malicious URI. Successful exploitation would result in arbitrary code executing in the client browser and possible theft of confidential data (such as authentication cookies).

Solution

Upgrade to version 1.9.7 or higher.

Plugin Details

Severity: Medium

ID: 3017

Family: CGI

Published: 2005/06/16

Modified: 2016/02/05

Dependencies: 1442

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 4.3

Temporal Score: 4.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:F/RL:U/RC:ND

CVSSv3

Base Score: 3.6

Temporal Score: 3.5

Vector: CVSS3#AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N

Temporal Vector: CVSS3#E:F/RL:U/RC:X

Reference Information

CVE: CVE-2005-2005, CVE-2005-2030, CVE-2005-2004

BID: 13975, 13971