CROB FTP Server Multiple Command Remote Overflow DoS

Medium Nessus Network Monitor Plugin ID 2945

Synopsis

The remote host is vulnerable to a buffer overflow.

Description

The remote host is running the CROB FTP Server. This version of CROB is vulnerable to a remote stack-based overflow when sent a malformed RMD command. An attacker exploiting this flaw would be able to execute arbitrary code. In addition, there are also multiple heap-based overflows within many other FTP commands.

Solution

No solution is known at this time.

Plugin Details

Severity: Medium

ID: 2945

Family: FTP Servers

Published: 2005/06/03

Updated: 2019/03/06

Dependencies: 1803, 1804

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5

Temporal Score: 4.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:F/RL:U/RC:ND

CVSS v3.0

Base Score: 5.3

Temporal Score: 5.2

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

Temporal Vector: CVSS:3.0/E:F/RL:U/RC:X

Vulnerability Information

CPE: cpe:/a:crob:crob_ftp_server

Reference Information

CVE: CVE-2005-1873, CVE-2006-6558

BID: 13847, 13848