WordPress < 1.5.1.2 Multiple Vulnerabilities

High Nessus Network Monitor Plugin ID 2918

Synopsis

The remote server is hosting an outdated installation of WordPress that is vulnerable to multiple attack vectors.

Description

Versions of WordPress prior to 1.5.1.2 are vulnerable to various flaws that may allow an attacker to perform a SQL injection attack against the remote host. Successful exploitation would allow an attacker to read/write confidential data as well as potentially execute arbitrary code on the remote database. In addition, the remote host is vulnerable to multiple cross-site scripting (XSS) flaws.

Solution

Upgrade to WordPress 1.5.1.2, or later.

See Also

http://wordpress.org/development/2005/05/security-update

Plugin Details

Severity: High

ID: 2918

File Name: 2918.prm

Family: CGI

Published: 2005/05/17

Modified: 2016/11/23

Dependencies: 9035

Nessus ID: 18301

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

CVSSv3

Base Score: 7.3

Temporal Score: 7

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:H/RL:O/RC:C

Reference Information

CVE: CVE-2005-1810

BID: 13655, 13809, 13663, 13664

OSVDB: 16905