Gaim < 1.3.0 Multiple Vulnerabilities

medium Nessus Network Monitor Plugin ID 2894
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote host is vulnerable to multiple attack vectors.

Description

The remote host appears to be running Gaim, a popular open-source, multi-protocol instant messenger. It is reported that this version of Gaim is vulnerable to several remote flaws. Namely

1) The MSN protocol module is vulnerable to a remote Denial of Service (DoS) attack when sent a NULL SLP message. Successful exploitation results in the application crashing.

2) Gaim instant messages support the sending of links (URIs). This version of Gaim only supports links of 8192 bytes or less. An attacker sending a link of more than 8192 bytes can overwrite memory and execute arbitrary code.

Solution

Update to Gaim 1.3.0 or higher.

Plugin Details

Severity: Medium

ID: 2894

Published: 5/11/2005

Updated: 3/6/2019

Dependencies: 2655

Risk Information

CVSS v2

Risk Factor: Medium

Base Score: 6.8

Temporal Score: 5

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3

Risk Factor: Medium

Base Score: 5.6

Temporal Score: 4.9

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:a:rob_flynn:gaim:*:*:*:*:*:*:*:*

Reference Information

CVE: CVE-2005-1261, CVE-2005-1262

BID: 13590, 13591