PHPCoin < 1.2.2 2005-12-13 Multiple Script SQL Injection (deprecated)

High Nessus Network Monitor Plugin ID 2867


The remote web server contains a script that is vulnerable to a SQL injection attack.


The remote host is running phpCOIN version 1.2.2 or older. This version of PHPCoin is vulnerable to a remote SQL injection attack. This vulnerability is possible due to the login.php and mod.php scripts not properly parsing SQL reserved characters from the user-supplied input. An attacker exploiting these flaws would be able to gain access to confidential materials with both read and write access. In addition, the attacker may be able to execute arbitrary code on the remote database server.


Upgrade to phpCOIN 1.2.2 with at least fix-file 2005-12-13 or higher.

See Also

Plugin Details

Severity: High

ID: 2867

File Name: 2867.prm

Family: CGI

Published: 2005/04/28

Modified: 2016/01/15

Dependencies: 1442

Nessus ID: 18166

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:H/RL:U/RC:ND


Base Score: 7.3

Temporal Score: 7.3


Temporal Vector: CVSS3#E:H/RL:U/RC:X

Reference Information

CVE: CVE-2005-4213, CVE-2005-4211, CVE-2005-4212, CVE-2005-1384

BID: 13433, 15830, 15831