Claroline Multiple Remote Vulnerabilities

High Nessus Network Monitor Plugin ID 2865

Synopsis

The remote web server contains a script that is vulnerable to a SQL injection attack.

Description

The remote host is running an older version of Claroline, an online e-learning software. This version is vulnerable to multiple attacks that include, but are not limited to, remote buffer overflow, HTML injection, Cross-Site Scripting (XSS), and SQL injection. An attacker exploiting these flaws can gain access to confidential data, run arbitrary code, and execute malicious code within victim browsers.

Solution

Upgrade or patch according to vendor recommendations.

See Also

http://www.nessus.org/u?5d5e500e

Plugin Details

Severity: High

ID: 2865

File Name: 2865.prm

Family: CGI

Published: 2005/04/27

Modified: 2016/01/15

Dependencies: 1442

Nessus ID: 18165

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

CVSSv3

Base Score: 7.3

Temporal Score: 7

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:H/RL:O/RC:C

Reference Information

CVE: CVE-2005-1377, CVE-2005-1374, CVE-2005-1375, CVE-2005-1376

BID: 13407