PHPBB2 < 2.0.14 Multiple Vulnerabilities

Medium Nessus Network Monitor Plugin ID 2820

Synopsis

The remote host is running phpBB2, a web-based bulletin board written in PHP.

Description

The remote host is running phpBB2, a web-based bulletin board written in PHP. This version of phpBB2 is vulnerable to multiple Cross-Site Scripting (XSS) attacks. An attacker exploiting this flaw would need to be able to entice a user into browsing a malicious URI. Successful exploitation would lead to the attacker executing code within the client browser possibly resulting in the theft of confidential data.

Solution

Upgrade to version 2.0.14 or higher.

See Also

http://archives.neohapsis.com/archives/bugtraq/2005-04/0190.html

Plugin Details

Severity: Medium

ID: 2820

Family: CGI

Published: 2005/04/13

Modified: 2016/01/21

Dependencies: 1442

Nessus ID: 18573

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 5.8

Temporal Score: 4.8

Vector: CVSS2#AV:A/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 6.3

Temporal Score: 5.9

Vector: CVSS3#AV:A/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Reference Information

CVE: CVE-2005-1116, CVE-2007-5100, CVE-2005-1113, CVE-2005-1114, CVE-2005-1115

BID: 13149, 13150, 13152, 13151, 13153, 13155, 13157, 25776, 13158