XAMPP < 1.4.14 Default Installation Multiple HTML Injection (deprecated)

High Nessus Network Monitor Plugin ID 2816

Synopsis

The remote host is running the XAMPP web server, a version of Apache that comes pre-bundled with Perl, MySQL, and PHP.

Description

The remote host is running the XAMPP web server, a version of Apache that comes pre-bundled with Perl, MySQL, and PHP. This version of XAMPP is reported to be prone to remote HTML injection attacks. An attacker, exploiting this flaw, would need to be able to convince a user to browse to a malicious URI. Successful exploitation would result in the attacker executing malicious code within the user's browser, possibly leading to theft of confidential data.

Solution

Upgrade to version 1.4.14 or higher.

See Also

http://archives.neohapsis.com/archives/fulldisclosure/2005-04/0236.html

Plugin Details

Severity: High

ID: 2816

File Name: 2816.prm

Family: CGI

Published: 2005/04/12

Modified: 2016/01/21

Dependencies: 1442

Nessus ID: 18036, 18037

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.5

Temporal Score: 7.1

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:U/RC:ND

CVSSv3

Base Score: 7.3

Temporal Score: 7.1

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:F/RL:U/RC:X

Reference Information

CVE: CVE-2005-1078, CVE-2005-1077, CVE-2005-2043

BID: 13126, 13127, 13128, 13131, 13982, 13983