Brooky CubeCart < 2.0.7 Multiple Script SQL Injection

High Nessus Network Monitor Plugin ID 2801

Synopsis

The remote web server contains a script that is vulnerable to a SQL injection attack.

Description

The remote host is using Brooky CubeCart, an online storefront application written in PHP. This version of CubeCart is vulnerable to multiple remote SQL injection flaws. An attacker exploiting these flaws would send a malformed HTTP request to the application. Successful exploitation would result in viewing of confidential data, modification of confidential data, and potentially arbitrary code execution. The flawed PHP scripts are 'index.php', 'tellafriend.php', 'view_cart.php', and 'view_product.php'

Solution

Upgrade to version 2.0.7 or higher..

See Also

http://archives.neohapsis.com/archives/bugtraq/2005-04/0083.html

Plugin Details

Severity: High

ID: 2801

File Name: 2801.prm

Family: CGI

Published: 2005/04/07

Modified: 2016/01/15

Dependencies: 1442

Nessus ID: 17999

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.5

Temporal Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:H/RL:U/RC:ND

CVSSv3

Base Score: 7.3

Temporal Score: 7.3

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:H/RL:U/RC:X

Reference Information

CVE: CVE-2005-1033

BID: 13050