Gaim < 1.2.1 Multiple Vulnerabilities

medium Nessus Network Monitor Plugin ID 2793

Synopsis

The remote host is vulnerable to multiple attack vectors.

Description

The remote host seems to be running Gaim, a popular open-source multi-protocol instant messenger. It is reported that this version of Gaim is prone to a flaw in the way that it handles malformed HTML data. Specifically, a content-parsing flaw in the 'gaim_markup_strip_html' function can cause the application to fail, leading to a loss of availability. Further, there are reported flaws within the IRC and Jabber plugins that can lead to a remote Denial of Service. In addition, it is reported that a flaw within the IRC plugin can allow the injection of Gaim scripting language commands.

Solution

Update to Gaim 1.2.1 or higher.

Plugin Details

Severity: Medium

ID: 2793

Published: 4/6/2005

Updated: 3/6/2019

Dependencies: 2655

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5.8

Temporal Score: 4.3

Vector: CVSS2#AV:A/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 6.3

Temporal Score: 5.5

Vector: CVSS:3.0/AV:A/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:a:rob_flynn:gaim:*:*:*:*:*:*:*:*

Reference Information

CVE: CVE-2005-0965, CVE-2005-0966, CVE-2005-0967

BID: 12999, 13003, 13004