phpMyAdmin < 2.6.2-RC1 RCE

Medium Nessus Network Monitor Plugin ID 2787

Synopsis

The remote web server contains a PHP application that is affected by a remote code execution vulnerability.

Description

The remote host is running phpMyAdmin, an open-source software written in PHP to handle the administration of MySQL over the Web. The remote host is vulnerable to a remote Cross-Site Scripting (XSS) flaw. An attacker exploiting these flaws would be need to be able to convince a user to click on a malicious URL. Upon successful exploitation, the attacker would be able to steal credentials or execute code within the browser.

Solution

Upgrade to phpMyAdmin 2.6.2 RC1, or later.

See Also

https://www.phpmyadmin.net

Plugin Details

Severity: Medium

ID: 2787

File Name: 2787.prm

Family: CGI

Published: 2005/04/04

Modified: 2016/03/02

Dependencies: 9102

Nessus ID: 17689

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 4.3

Temporal Score: 3.7

Vector: CVSS2#AV:A/AC:M/Au:N/C:P/I:P/A:N

Temporal Vector: CVSS2#E:H/RL:OF/RC:ND

CVSSv3

Base Score: 4.1

Temporal Score: 3.9

Vector: CVSS3#AV:A/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N

Temporal Vector: CVSS3#E:H/RL:O/RC:X

Vulnerability Information

CPE: cpe:/a:phpmyadmin:phpmyadmin

Reference Information

CVE: CVE-2005-0992

BID: 12982, 13452