PuTTY < 0.57 SFTP Remote Buffer Overflow

High Nessus Network Monitor Plugin ID 2637

Synopsis

The remote host is vulnerable to a buffer overflow.

Description

The remote host is using a vulnerable version of PuTTY, a SSH client built for Linux and UNIX variants as well as Microsoft Windows operating systems. This version of PuTTY does not properly handle an integer value passed from the SSH Server during an SFTP connection. An attacker exploiting this flaw would need to be able to convince a user to use PuTTY to initiate an SFTP connection to a malicious SSH server. Successful exploitation would result in PuTTY crashing or possibly executing arbitrary commands.

Solution

Upgrade to PuTTY 0.57 or higher.

Plugin Details

Severity: High

ID: 2637

Family: SSH

Published: 2005/02/22

Modified: 2016/11/23

Dependencies: 1968

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.6

Temporal Score: 5.6

Vector: CVSS2#AV:N/AC:H/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSSv3

Base Score: 8.1

Temporal Score: 7

Vector: CVSS3#AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS3#E:U/RL:O/RC:C

Reference Information

CVE: CVE-2005-0467

BID: 12601