ISC BIND < 8.4.6 q_usedns Array Remote Overflow DoS (deprecated)

Medium Nessus Network Monitor Plugin ID 2556

Synopsis

The remote host is vulnerable to a Denial of Service (DoS) attack.

Description

The remote BIND DNS server is, according to its version number, vulnerable to a remote buffer overflow in the 'q_usedns' buffer. An attacker may be able to launch a denial of service attack against the remote BIND Server.

Solution

Upgrade to Bind 8.4.6 or higher or the newest version of BIND 9.

See Also

http://www.kb.cert.org/vuls/id/327633

Plugin Details

Severity: Medium

ID: 2556

Family: DNS Servers

Published: 2005/01/26

Updated: 2019/03/06

Dependencies: 1000

Nessus ID: 16260

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 5.3

Temporal Score: 4.6

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:isc:bind:8.4

Reference Information

CVE: CVE-2005-0033

BID: 12364