WordPress < 1.2.2 Multiple Vulnerabilities

Medium Nessus Network Monitor Plugin ID 2465

Synopsis

The remote server is hosting an outdated installation of WordPress that is vulnerable to multiple attack vectors.

Description

Versions of WordPress prior to 1.2.2 are vulnerable to various flaws that may allow an attacker to perform an HTML injection attack against the remote host or to allow an attacker to execute arbitrary SQL statements against the remote database.

Solution

Upgrade to WordPress 1.2.2 or higher.

See Also

http://www.securityfocus.com/archive/1/377770

Plugin Details

Severity: Medium

ID: 2465

Family: CGI

Published: 2004/12/16

Modified: 2016/01/21

Dependencies: 9035

Nessus ID: 15443

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 4.3

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

CVSSv3

Base Score: 5.3

Temporal Score: 5.1

Vector: CVSS3#AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N

Temporal Vector: CVSS3#E:H/RL:O/RC:C

Reference Information

CVE: CVE-2004-1584

BID: 11348, 11984, 12066