phpMyAdmin < 2.5.2 Multiple Vulnerabilities

Medium Nessus Network Monitor Plugin ID 2420

Synopsis

The remote web server contains a PHP application that is affected by multiple vulnerabilities.

Description

The remote host is running phpMyAdmin, an open-source software written in PHP to handle the administration of MySQL over the Web.
The remote version of this software is vulnerable to several flaws :
- It may be tricked into disclosing the physical path of the remote PHP installation
- It is vulnerable to cross-site scripting, which may allow an attacker to steal the cookies of your users
- It is vulnerable to a flaw that may allow an attacker to list the content of arbitrary directories on the remote server.
An attacker may use these flaws to gain more knowledge about the remote host and therefore set up more complex attacks against it.

Solution

Upgrade to phpMyAdmin 2.5.2 or higher.

See Also

http://www.securityfocus.com/archive/1/325641

http://www.securityfocus.com/archive/1/327511

Plugin Details

Severity: Medium

ID: 2420

File Name: 2420.prm

Family: CGI

Published: 2004/11/22

Modified: 2016/02/29

Dependencies: 9102

Nessus ID: 11761

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 5

Temporal Score: 4.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

CVSSv3

Base Score: 5.3

Temporal Score: 5.1

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

Temporal Vector: CVSS3#E:H/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:phpmyadmin:phpmyadmin

Reference Information

BID: 7963, 7964, 7965, 7962

OSVDB: 8450, 8451, 8452, 8453, 8454, 8455, 8456, 8457, 8458, 8459, 8460, 8461, 8462, 8463, 8464, 8465, 8466, 8467, 8468, 8469, 8470, 8471, 8472, 8473, 8474, 8475, 8476, 8477, 8478, 8479, 8480, 8481, 8482, 8483, 8484, 8485, 8486, 8487, 8488, 8489, 8490, 8491, 8492, 8493, 8494, 8495, 8496, 8497, 8498, 8499, 8500, 8501, 8502, 8503, 8504, 8505