phpMyAdmin < 2.5.6-rc1 Arbitrary File Access

Medium Nessus Network Monitor Plugin ID 2419

Synopsis

The remote host is vulnerable to a flaw that allows attackers to retrieve sensitive files or data.

Description

Versions of phpMyAdmin prior to 2.5.6-rc1 are affected by a file access flaw. It is possible to make the remote phpMyAdmin installation read arbitrary data on the remote host by using a malformed URL. An attacker may use this flaw to read '/etc/passwd' or any file that a web server has the right to access.

Solution

Upgrade to phpMyAdmin 2.5.6-rc1 or higher.

See Also

http://archives.neohapsis.com/archives/bugtraq/2004-02/0062.html

http://sourceforge.net/forum/forum.php?forum_id=350228

Plugin Details

Severity: Medium

ID: 2419

Family: CGI

Published: 2004/11/22

Modified: 2016/03/02

Dependencies: 9102

Nessus ID: 12041

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 5.1

Temporal Score: 4.4

Vector: CVSS2#AV:N/AC:H/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

CVSSv3

Base Score: 5.6

Temporal Score: 5.3

Vector: CVSS3#AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:H/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:phpmyadmin:phpmyadmin

Reference Information

CVE: CVE-2004-0129

BID: 9564