phpMyAdmin < 2.2.1 'sql.php' Arbitrary File Access

Medium Nessus Network Monitor Plugin ID 2418

Synopsis

The remote host is vulnerable to a flaw that allows attackers to retrieve sensitive files or data.

Description

Versions of phpMyAdmin prior to 2.2.1 are affected by a flaw that makes the remote phpMyAdmin installation read arbitrary data on the remote host by using a malformed URL.
An attacker may use this flaw to read /etc/passwd or any file that the web server has the right to access.

Solution

Upgrade to phpMyAdmin 2.2.1 or later.

See Also

http://archives.neohapsis.com/archives/bugtraq/2001-04/0396.html

Plugin Details

Severity: Medium

ID: 2418

Family: CGI

Published: 2004/11/22

Modified: 2016/02/29

Dependencies: 9102

Nessus ID: 11116

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 5.1

Temporal Score: 3.8

Vector: CVSS2#AV:N/AC:H/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:ND

CVSSv3

Base Score: 5.6

Temporal Score: 4.8

Vector: CVSS3#AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:U/RL:O/RC:X

Vulnerability Information

CPE: cpe:/a:phpmyadmin:phpmyadmin

Reference Information

CVE: CVE-2001-0478

BID: 2642