phpMyAdmin < 2.6.0-p13 XSS

Medium Nessus Network Monitor Plugin ID 2417

Synopsis

The remote web server contains a PHP application that is affected by a cross-site scripting (XSS) vulnerability.

Description

Versions of phpMyAdmin prior to 2.6.0-p13 are vulnerable to cross-site scripting attacks through multiple scripts. With a specially crafted URL, an attacker may use the remote host to perform a cross site scripting attack.

Solution

Upgrade to phpMyAdmin 2.6.0-pl3 or higher.

See Also

http://www.netvigilance.com/html/advisory0005.htm

http://www.phpmyadmin.net/home_page/security.php?issue=PMASA-2004-3

Plugin Details

Severity: Medium

ID: 2417

File Name: 2417.prm

Family: CGI

Published: 2004/11/22

Modified: 2016/02/29

Dependencies: 9102

Nessus ID: 15770

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 4.3

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

CVSSv3

Base Score: 5.3

Temporal Score: 5.1

Vector: CVSS3#AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N

Temporal Vector: CVSS3#E:H/RL:O/RC:X

Vulnerability Information

CPE: cpe:/a:phpmyadmin:phpmyadmin

Reference Information

CVE: CVE-2004-1055

BID: 11707

OSVDB: 11930, 11931, 11932, 12238