Moodle < 1.4.3 Glossary Module SQLi

High Nessus Network Monitor Plugin ID 2388

Synopsis

The remote web server contains a script that is vulnerable to a SQL injection attack.

Description

The remote host is running a version of the Moodle suite, an open-source course management system written in PHP, that is older than version 1.4.3.
The remote version of this software is vulnerable to a SQL injection issue in the 'glossary' module due to a lack of user input sanitization.

Solution

Upgrade to Moodle 1.4.3 or higher.

See Also

http://archives.neohapsis.com/archives/bugtraq/2004-12/0427.html

http://archives.neohapsis.com/archives/bugtraq/2004-12/0464.html

Plugin Details

Severity: High

ID: 2388

Family: CGI

Published: 2004/11/06

Modified: 2016/11/23

Dependencies: 8683

Nessus ID: 15639

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

CVSSv3

Base Score: 7.3

Temporal Score: 7

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:H/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:moodle:moodle

Patch Publication Date: 2004/09/29

Vulnerability Publication Date: 2004/09/29

Reference Information

CVE: CVE-2004-2232, CVE-2004-1424, CVE-2004-1425

BID: 11608, 11691, 12120