YaBB < Gold SP 1.3.2 Multiple Input Validation Vulnerabilities

Low Nessus Network Monitor Plugin ID 2312

Synopsis

The remote host is vulnerable to a Cross-Site Scripting (XSS) attack.

Description

The remote host is running a vulnerable version of YaBB. It is reported that versions up to and including 1 Gold SP 1.3.1 are prone to multiple input validation vulnerabilities. Using these weaknesses, an attacker may influence how web content is served, cached and interpreted or perform cross-site scripting attacks to steal cookie-based authentication credentials from an unsuspecting user.

Solution

Upgrade to YaBB Gold SP 1.3.2 or higher.

Plugin Details

Severity: Low

ID: 2312

File Name: 2312.prm

Family: CGI

Published: 2004/09/23

Modified: 2016/02/05

Dependencies: 1442

Risk Information

Risk Factor: Low

CVSSv2

Base Score: 2.6

Temporal Score: 2.3

Vector: CVSS2#AV:N/AC:H/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

CVSSv3

Base Score: 3.6

Temporal Score: 3.4

Vector: CVSS3#AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N

Temporal Vector: CVSS3#E:H/RL:O/RC:C

Reference Information

CVE: CVE-2004-2140, CVE-2004-2139

BID: 11235

OSVDB: 10222