vBulletin authorize.php x_invoice_num Parameter SQL Injection

High Nessus Network Monitor Plugin ID 2294

Synopsis

The remote web server contains a script that is vulnerable to a SQL injection attack.

Description

The remote host is running a version of vBulletin, a forum application implemented in PHP, that is vulnerable to a SQL injection issue. It is reported that versions 3.0.0 through to 3.0.3 are prone to this issue. An attacker may steal content from the underlying database or attack it.

Solution

Upgrade or patch according to vendor recommendations.

Plugin Details

Severity: High

ID: 2294

File Name: 2294.prm

Family: CGI

Published: 2004/09/15

Modified: 2016/01/15

Dependencies: 1442

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

CVSSv3

Base Score: 7.3

Temporal Score: 7

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:H/RL:O/RC:C

Reference Information

CVE: CVE-2004-2695

BID: 11193, 11658

OSVDB: 9993