OpenCA < 0.9.1-9 Web Interface Form Input Field XSS

Medium Nessus Network Monitor Plugin ID 2267

Synopsis

The remote host is vulnerable to an Cross-Site Scripting (XSS) attack.

Description

The remote host appears to be running OpenCA. It is reported that OpenCA versions up to and including 0.9.2-RC2 are prone to a cross-site scripting vulnerability when processing user inputs into the web form frontend. This issue may permit an attacker to execute hostile HTML code in the context of another user.

Solution

Upgrade to version 0.9.1-9 or higher.

Plugin Details

Severity: Medium

ID: 2267

Family: CGI

Published: 2004/09/07

Modified: 2018/09/16

Dependencies: 1442

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 4.3

Temporal Score: 4.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:H/RL:U/RC:C

CVSSv3

Base Score: 3.6

Temporal Score: 3.6

Vector: CVSS3#AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N

Temporal Vector: CVSS3#E:H/RL:U/RC:C

Vulnerability Information

CPE: cpe:/a:openca:openca

Reference Information

CVE: CVE-2004-0787

BID: 11113