Mantis < 0.18.3 / 0.19.0a2 Multiple Vulnerabilities

Medium Nessus Network Monitor Plugin ID 2114

Synopsis

The remote host is vulnerable to an HTML injection attack.

Description

The remote host seems to be running a vulnerable version of Mantis, a bug tracker web application written in PHP. It is reported that versions up to 0.18.0 and 0.19.0a1 are prone to multiple flaws that may allow a remote attacker to inject malicious HTML in webpages, to execute arbitrary code on the remote host or to perform a mass mailing.

Solution

Upgrade to Mantis version 0.18.3 or 0.19.0a2 or higher.

See Also

http://marc.info/?l=bugtraq&amp;m=109312225727345&amp;w=2

http://marc.info/?l=bugtraq&amp;m=109313416727851&amp;w=2

Plugin Details

Severity: Medium

ID: 2114

File Name: 2114.prm

Family: CGI

Published: 2004/08/18

Modified: 2016/02/05

Dependencies: 1442

Nessus ID: 14324

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 6.8

Temporal Score: 6.5

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:H/RL:W/RC:C

CVSSv3

Base Score: 5.6

Temporal Score: 5.4

Vector: CVSS3#AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:H/RL:W/RC:C

Reference Information

CVE: CVE-2004-1734, CVE-2004-1730, CVE-2004-1731

BID: 10993, 10994, 10995