Putty < 0.54 SSH2 Authentication Password Persistence Weakness

Low Nessus Network Monitor Plugin ID 1999

Synopsis

The remote host is vulnerable to a flaw that allows attackers to retrieve sensitive files or data.

Description

The remote host is using a vulnerable version of PuTTY, a SSH client built for Linux and UNIX variants as well as Microsoft Windows operation systems. It has been reported that PuTTY does not safely handle password information. As a result, a local user may be able to recover authentication passwords.

Solution

Upgrade to PuTTY 0.54 or higher.

Plugin Details

Severity: Low

ID: 1999

Family: SSH

Published: 2004/08/20

Modified: 2016/11/23

Dependencies: 1968

Risk Information

Risk Factor: Low

CVSSv2

Base Score: 3.6

Temporal Score: 3.6

Vector: CVSS2#AV:L/AC:L/Au:N/C:P/I:P/A:N

Temporal Vector: CVSS2#E:H/RL:U/RC:C

CVSSv3

Base Score: 5.1

Temporal Score: 5.1

Vector: CVSS3#AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N

Temporal Vector: CVSS3#E:H/RL:U/RC:C

Reference Information

CVE: CVE-2003-0048

BID: 6724