PuTTY < 0.55 modpow Function Arbitrary Code Execution

Medium Nessus Network Monitor Plugin ID 1998


The remote host is vulnerable to a buffer overflow.


The remote host is using a vulnerable version of PuTTY or of a PuTTY-based software (eg. PSCP or WinSCP). PuTTY is a SSH client built for Linux and UNIX variants as well as Microsoft Windows operating systems. Reportedly PuTTY is affected by a remote, pre-authentication memory corruption vulnerability and by a buffer overrun in its SCP client.


Upgrade to PuTTY 0.55 or higher.

Plugin Details

Severity: Medium

ID: 1998

Family: SSH

Published: 2004/08/20

Modified: 2018/07/11

Dependencies: 1968

Risk Information

Risk Factor: Medium


Base Score: 5.1

Temporal Score: 5

Vector: CVSS2#AV:N/AC:H/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C


Base Score: 5.6

Temporal Score: 4.9


Temporal Vector: CVSS3#E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:putty:putty

Reference Information

CVE: CVE-2004-1440

BID: 10870, 10850