Portable OpenSSH < 3.7.1p2 Multiple PAM Vulnerabilities

Medium Nessus Network Monitor Plugin ID 1996

Synopsis

The remote host is vulnerable to a flaw that allows for the bypassing of authentication.

Description

The remote host is portable OpenSSH 3.7p1 or 3.7.1p1.
Versions older than 3.7.1p2 are vulnerable to a flaws that handle PAM authentication and may allow an attacker to gain a shell on this host.

Solution

Upgrade to OpenSSH 3.7.1p2 or higher or disable PAM support in sshd_config.

See Also

http://www.kb.cert.org/vuls/id/602204

Plugin Details

Severity: Medium

ID: 1996

File Name: 1996.prm

Family: SSH

Published: 2004/08/20

Modified: 2016/11/23

Dependencies: 1997, 3059

Nessus ID: 11848

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 6.2

Temporal Score: 5.1

Vector: CVSS2#AV:L/AC:H/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 7.3

Temporal Score: 6.7

Vector: CVSS3#AV:L/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:openbsd:openssh

Reference Information

CVE: CVE-2003-0787, CVE-2003-0786

BID: 8677