OpenSSH < 3.0.2 UseLogin Environment Variable Local Command Execution

High Nessus Network Monitor Plugin ID 1992

Synopsis

The remote host is vulnerable to a flaw that allows for the bypassing of authentication.

Description

The remote host is running a version of OpenSSH that is older than 3.0.2. Versions prior than 3.0.2 are vulnerable to an environment variables export that can allow a local user to execute command with root privileges. This problem affects only versions prior than 3.0.2 when the UseLogin feature is enabled (usually disabled by default).

Note: PVS has solely relied on the banner of the SSH client to perform this check. Any backported patches or workarounds such as recompiling or edited configurations are not observable through the banner.

Solution

Upgrade to OpenSSH 3.0.2 or higher.

Plugin Details

Severity: High

ID: 1992

Family: SSH

Published: 2004/08/20

Modified: 2016/11/23

Dependencies: 1997, 3059

Nessus ID: 10823

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.2

Temporal Score: 5.3

Vector: CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSSv3

Base Score: 8.4

Temporal Score: 7.3

Vector: CVSS3#AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS3#E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:openbsd:openssh

Reference Information

CVE: CVE-2001-0872

BID: 3614