OpenSSH < 3.4 Multiple Remote Overflows

High Nessus Network Monitor Plugin ID 1987

Synopsis

The remote host is vulnerable to a buffer overflow.

Description

The remote host is running a version of OpenSSH which is older than 3.4. There is a flaw in this version that can be exploited remotely to give an attacker a shell on this host. Note that several distributions patched this hole without changing the version number of OpenSSH.

If you are running a RedHat host, make sure that the command :
rpm -q openssh-server
Returns : openssh-server-3.1p1-6.

Note: PVS has solely relied on the banner of the SSH client to perform this check. Any backported patches or workarounds such as recompiling or edited configurations are not observable through the banner.

Solution

Upgrade to OpenSSH 3.4 or contact your vendor for a patch.

See Also

http://www.openssh.com/txt/preauth.adv

Plugin Details

Severity: High

ID: 1987

Family: SSH

Published: 2004/08/20

Modified: 2016/11/23

Dependencies: 1997, 3059

Nessus ID: 11031

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.2

Temporal Score: 6

Vector: CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 8.4

Temporal Score: 7.8

Vector: CVSS3#AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:openbsd:openssh

Reference Information

CVE: CVE-2002-0639, CVE-2002-0640

BID: 5093