UoW imapd (UW-IMAP) v12 Multiple Command Remote Overflows

High Nessus Network Monitor Plugin ID 1087

Synopsis

The remote host is vulnerable to a buffer overflow.

Description

There is a buffer overflow in the remote IMAP4 server which allows an authenticated user to obtain a remote shell.

Solution

Upgrade your IMAP server or use another one.

See Also

http://archives.neohapsis.com/archives/bugtraq/2000-04/0085.html

http://packetstormsecurity.org/0104-exploits/imap-lsub.pl

http://www.ca.com/us/securityadvisor/vulninfo/vuln.aspx?id=2442

http://archives.neohapsis.com/archives/bugtraq/2000-04/0074.html

Plugin Details

Severity: High

ID: 1087

Family: IMAP Servers

Published: 2004/08/20

Modified: 2016/11/23

Nessus ID: 10625

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.5

Temporal Score: 7.1

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:U/RC:C

CVSSv3

Base Score: 7.3

Temporal Score: 7.1

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:F/RL:U/RC:C

Exploitable With

Metasploit (UoW IMAP server LSUB Buffer Overflow)

Reference Information

CVE: CVE-2000-0284

BID: 1110