Joomla! 2.5.x < 2.5.25 / 3.x < 3.2.5 / 3.3.x < 3.3.4 Multiple Vulnerabilities

critical Nessus Plugin ID 77860


The remote web server contains a PHP application that is affected by multiple vulnerabilities.


According to its self-reported version number, the Joomla! installation running on the remote web server is 2.5.x prior to 2.5.25, 3.x prior to 3.2.5, or 3.3.x prior to 3.3.4. It is, therefore, affected by multiple vulnerabilities :

- A cross-site scripting (XSS) vulnerability exists in the com_media component due to improper sanitization of input before returning it to users. An unauthenticated, remote attacker can exploit this, via a specially crafted request, to execute arbitrary script code within a user's browser session. Note that this issue only affects versions 3.2.x prior to 3.2.5 and 3.3.x prior to 3.3.4. (CVE-2014-6631)

- An authentication bypass vulnerability exists in the LDAP extension due to a failure to restrict NULL bytes.
An unauthenticated, remote attacker can exploit this, via a specially crafted request, to bypass LDAP authentication and login as a different user without knowing the user's password. (CVE-2014-6632)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.


Upgrade to Joomla! version 2.5.25 / 3.2.5 / 3.3.4 or later.

See Also

Plugin Details

Severity: Critical

ID: 77860

File Name: joomla_334.nasl

Version: 1.14

Type: remote

Family: CGI abuses

Published: 9/25/2014

Updated: 6/5/2024

Configuration: Enable paranoid mode, Enable thorough checks

Supported Sensors: Nessus

Enable CGI Scanning: true

Risk Information


Risk Factor: Medium

Score: 5.8


Risk Factor: High

Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P


Risk Factor: Critical

Base Score: 9.8

Temporal Score: 8.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:joomla:joomla%5c%21

Required KB Items: www/PHP, Settings/ParanoidReport, installed_sw/Joomla!

Excluded KB Items: Settings/disable_cgi_scanning

Exploit Ease: No known exploits are available

Patch Publication Date: 9/23/2014

Vulnerability Publication Date: 3/7/2007

Reference Information

CVE: CVE-2014-6631, CVE-2014-6632

BID: 70076, 70077

CWE: 20, 442, 629, 711, 712, 722, 725, 74, 750, 751, 79, 800, 801, 809, 811, 864, 900, 928, 931, 990