Microsoft Internet Explorer 8 CMarkup Use-After-Free Remote Code Execution

high Nessus Plugin ID 74138
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote host has a version of Internet Explorer installed that is affected by a remote code execution vulnerability.

Description

The remote host has a version of Microsoft Internet Explorer installed that is affected by a use-after-free remote code execution vulnerability related to the handling of CMarkup objects.

Solution

Apply the workarounds mentioned in the CERT and ZDI advisories.

See Also

http://zerodayinitiative.com/advisories/ZDI-14-140/

http://www.nessus.org/u?b062019d

Plugin Details

Severity: High

ID: 74138

File Name: smb_ie_cve_2014_1770.nasl

Version: Revision: 1.4

Type: local

Agent: windows

Family: Windows

Published: 5/22/2014

Updated: 6/12/2014

Dependencies: microsoft_emet_installed.nasl, smb_hotfixes.nasl, microsoft_ie_esc_detect.nbin

Risk Information

CVSS v2

Risk Factor: High

Base Score: 9.3

Temporal Score: 8.1

Vector: AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: E:ND/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/o:microsoft:windows, cpe:/a:microsoft:ie

Required KB Items: SMB/Registry/Enumerated, SMB/WindowsVersion, SMB/IE/Version

Exploit Ease: No known exploits are available

Vulnerability Publication Date: 5/21/2014

Reference Information

CVE: CVE-2014-1770

BID: 67544

OSVDB: 107182

CERT: 239151