MS KB2639658: Vulnerability in TrueType Font Parsing Could Allow Elevation of Privilege (DEPRECATED)

High Nessus Plugin ID 56711


The remote Windows host has a code execution vulnerability in its font parsing engine.


The remote host has an unspecified code execution vulnerability in the Win32k TrueType font parsing engine. Specially crafted TrueType fonts are not properly handled, which could allow arbitrary code execution in kernel mode. A remote attacker could exploit this vulnerability by tricking a user into viewing a specially crafted TrueType font (e.g., via web or email).

This vulnerability is reportedly exploited by the Duqu malware and is being exploited in the wild.

Note that this plugin has been deprecated on December 13, 2011 with the publication by Microsoft of MS11-087.


Apply the workaround referenced in Microsoft Security Advisory (2639658). This workaround may cause some fonts to display improperly. Refer to the advisory for more information.

See Also

Plugin Details

Severity: High

ID: 56711

File Name: smb_kb2639658.nasl

Version: $Revision: 1.12 $

Type: local

Agent: windows

Family: Windows

Published: 2011/11/04

Modified: 2017/08/30

Dependencies: 13855

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 8

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:TF/RC:C

Vulnerability Information

CPE: cpe:/o:microsoft:windows

Required KB Items: SMB/Registry/Enumerated, SMB/WindowsVersion, SMB/ARCH

Exploit Available: true

Exploit Ease: Exploits are available

Vulnerability Publication Date: 2011/11/01

Reference Information

CVE: CVE-2011-3402

BID: 50462

OSVDB: 76843

CERT: 316553

MSKB: 2639658