MDKA-2005:045 : ghostscript

High Nessus Plugin ID 24471


The remote Mandrake host is missing one or more security-related patches.


New ghostscript packages are now available that provide ghostscript 8.15.1 final and provide a number of bug fixes, including:

A fix for vertical japanese text.

A memory overflow in the 'lips4' driver was fixed.

A double-free in gsdevice.c was fixed.

A SEGV in the 'inferno' driver was fixed; this was because the struct 'inferno_device' was not created but it was accessed to its elements.

The shared X11 driver was not built with the correct linker command (CCLD instead of CC_SHARED).

The 'opvp' driver incorrectly assumed that CODESET was supported on all platforms that supported iconv.

Support in the 'cups' driver for CUPS_CSPACE_RGBW colorspace was added.

Other fixes are also included in these new packages.


Update the affected package(s).

See Also

Plugin Details

Severity: High

ID: 24471

File Name: mandrake_MDKA-2005-045.nasl

Version: $Revision: 1.9 $

Type: local

Published: 2007/02/18

Modified: 2012/09/07

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: cpe:/o:mandriva:linux

Required KB Items: Host/Mandrake/release, Host/Mandrake/rpm-list

Patch Publication Date: 2005/10/11