MDKA-2005:044 : postgresql

High Nessus Plugin ID 24470


The remote Mandrake host is missing one or more security-related patches.


A number of bugs are corrected in PostgreSQL version 8.0.4 so an update for Mandrivalinux 2006 is now available (PostgreSQL 8.0.3 was provided). Fixes include various memory leakage fixes, improved checking for partially-written WAL pages, a fix for an error that allowed 'VACUUM' to remove ctid chains too soon, and other fixes.

A dump/reload of the databases are not required when upgrading from the provided 8.0.3 version, but may be required if upgrading from an ealier version (ie. upgrading from Mandrivalinux LE2005).


Update the affected package(s).

See Also

Plugin Details

Severity: High

ID: 24470

File Name: mandrake_MDKA-2005-044.nasl

Version: $Revision: 1.9 $

Type: local

Published: 2007/02/18

Modified: 2012/09/07

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: cpe:/o:mandriva:linux

Required KB Items: Host/Mandrake/release, Host/Mandrake/rpm-list

Patch Publication Date: 2005/10/11