MediaWiki < 1.3.17 / 1.4.11 / 1.5.0 Multiple Vulnerabilities

medium Nessus Plugin ID 19949


The remote web server contains a PHP application that is affected by multiple vulnerabilities.


According to its version number, the version of MediaWiki running on the remote host is affected by multiple vulnerabilities :

- A denial of service vulnerability exists due to an unspecified flaw in 'edit submission handling' that causes the corruption of the previous submission. A remote attacker can exploit this via a crafted URL. A spam bot known to be active in the wild can reportedly trigger this issue. (CVE-2005-3166)

- A cross-site scripting vulnerability exists due to improper sanitization of user-supplied input for HTML inline style attributes. (CVE-2005-3167)


Upgrade to MediaWiki 1.3.17 / 1.4.11 / 1.5.0 or later.

See Also

Plugin Details

Severity: Medium

ID: 19949

File Name: mediawiki_edit_history_corruption.nasl

Version: 1.23

Type: remote

Family: CGI abuses

Published: 10/11/2005

Updated: 6/5/2024

Configuration: Enable paranoid mode, Enable thorough checks

Supported Sensors: Nessus

Enable CGI Scanning: true

Risk Information


Risk Factor: Medium

Score: 4.2


Risk Factor: Medium

Base Score: 5

Temporal Score: 4.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:P/A:N

Vulnerability Information

CPE: cpe:/a:mediawiki:mediawiki

Required KB Items: www/PHP, Settings/ParanoidReport, installed_sw/MediaWiki

Excluded KB Items: Settings/disable_cgi_scanning

Exploit Available: true

Exploit Ease: No exploit is required

Vulnerability Publication Date: 10/5/2005

Reference Information

CVE: CVE-2005-3166, CVE-2005-3167

BID: 15024, 15041

CWE: 20, 442, 629, 711, 712, 722, 725, 74, 750, 751, 79, 800, 801, 809, 811, 864, 900, 928, 931, 990