RHEL 8 : ruby (Unpatched Vulnerability)

high Nessus Plugin ID 198400

Synopsis

The remote Red Hat 8 host is affected by a vulnerability that will not be patched.

Description

The remote Redhat Enterprise Linux 8 host has one or more packages installed that are affected by a vulnerability that has been acknowledged by the vendor but will not be patched.

- ruby: Buffer overrun in String-to-Float conversion (CVE-2022-28739)

Note that Nessus has not tested for this issue but has instead relied on the package manager's report that the package is installed.

Solution

The vendor has acknowledged the vulnerability but no solution has been provided. Refer to the vendor for remediation guidance.

Plugin Details

Severity: High

ID: 198400

File Name: redhat_unpatched_ruby-rhel8.nasl

Version: 1.3

Type: local

Agent: unix

Published: 6/3/2024

Updated: 7/12/2024

Supported Sensors: Agentless Assessment, Frictionless Assessment Agent, Frictionless Assessment AWS, Frictionless Assessment Azure, Nessus Agent, Nessus

Risk Information

VPR

Risk Factor: Medium

Score: 4.4

CVSS v2

Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.2

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:N/A:N

CVSS Score Source: CVE-2022-28739

CVSS v3

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:redhat:enterprise_linux:ruby, cpe:/o:redhat:enterprise_linux:8

Required KB Items: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list, Host/cpu

Exploit Ease: No known exploits are available

Vulnerability Publication Date: 9/9/2019

Reference Information

CVE: CVE-2022-28739