SSA-18703 zlib upgrade fixes vulnerability

High Nessus Plugin ID 18703


The remote host is missing a security update.


New zlib packages are available to fix a security problem which may impact programs that link with zlib.

Here's the information from the Slackware 8.0 ChangeLog:

---------------------------- Mon Mar 11 13:32:40 PST 2002 patches/packages/zlib.tgz: Upgraded to zlib-1.1.4. This fixes a security problem which may introduce vulnerabilities into any program that links with zlib. Quoting the advisory on

Depending upon how and where the zlib routines are called from the given program, the resulting vulnerability may have one or more of the following impacts: denial of service, information leakage, or execution of arbitrary code.

Sites are urged to upgrade the zlib package immediately.

The complete advisory may be found here:


Update the packages that are referenced in the security advisory

Plugin Details

Severity: High

ID: 18703

File Name: Slackware_18703.nasl

Version: $Revision: 1.7 $

Published: 2005/07/13

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

Required KB Items: Host/Slackware/release, Host/Slackware/packages