Rocky Linux 8 : php:7.4 (RLSA-2022:7628)

critical Nessus Plugin ID 184576

Synopsis

The remote Rocky Linux host is missing one or more security updates.

Description

The remote Rocky Linux 8 host has packages installed that are affected by multiple vulnerabilities as referenced in the RLSA-2022:7628 advisory.

- In PHP versions 7.3.x below 7.3.33, 7.4.x below 7.4.26 and 8.0.x below 8.0.13, certain XML parsing functions, like simplexml_load_file(), URL-decode the filename passed to them. If that filename contains URL-encoded NUL character, this may cause the function to interpret this as the end of the filename, thus interpreting the filename differently from what the user intended, which may lead it to reading a different file than intended. (CVE-2021-21707)

- In PHP versions 7.4.x below 7.4.28, 8.0.x below 8.0.16, and 8.1.x below 8.1.3, when using filter functions with FILTER_VALIDATE_FLOAT filter and min/max limits, if the filter fails, there is a possibility to trigger use of allocated memory after free, which can result it crashes, and potentially in overwrite of other memory chunks and RCE. This issue affects: code that uses FILTER_VALIDATE_FLOAT with min/max limits.
(CVE-2021-21708)

- In Archive_Tar before 1.4.14, symlinks can refer to targets outside of the extracted archive, a different vulnerability than CVE-2020-36193. (CVE-2021-32610)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Update the affected packages.

See Also

https://errata.rockylinux.org/RLSA-2022:7628

https://bugzilla.redhat.com/show_bug.cgi?id=1988558

https://bugzilla.redhat.com/show_bug.cgi?id=2026045

https://bugzilla.redhat.com/show_bug.cgi?id=2055422

https://bugzilla.redhat.com/show_bug.cgi?id=2055879

Plugin Details

Severity: Critical

ID: 184576

File Name: rocky_linux_RLSA-2022-7628.nasl

Version: 1.0

Type: local

Published: 11/6/2023

Updated: 11/6/2023

Supported Sensors: Nessus

Risk Information

VPR

Risk Factor: Medium

Score: 6.7

CVSS v2

Risk Factor: Medium

Base Score: 6.8

Temporal Score: 5.6

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

CVSS Score Source: CVE-2021-21708

CVSS v3

Risk Factor: Critical

Base Score: 9.8

Temporal Score: 9.1

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:rocky:linux:php-dbg-debuginfo, p-cpe:/a:rocky:linux:php-debuginfo, p-cpe:/a:rocky:linux:php-debugsource, p-cpe:/a:rocky:linux:php-devel, p-cpe:/a:rocky:linux:php-embedded, p-cpe:/a:rocky:linux:php-embedded-debuginfo, p-cpe:/a:rocky:linux:php-enchant, p-cpe:/a:rocky:linux:php-enchant-debuginfo, p-cpe:/a:rocky:linux:php-ffi, p-cpe:/a:rocky:linux:php-ffi-debuginfo, p-cpe:/a:rocky:linux:php-fpm, p-cpe:/a:rocky:linux:php-fpm-debuginfo, p-cpe:/a:rocky:linux:php-gd, p-cpe:/a:rocky:linux:php-gd-debuginfo, p-cpe:/a:rocky:linux:php-gmp, p-cpe:/a:rocky:linux:php-gmp-debuginfo, p-cpe:/a:rocky:linux:php-intl, p-cpe:/a:rocky:linux:php-intl-debuginfo, p-cpe:/a:rocky:linux:php-json, p-cpe:/a:rocky:linux:php-json-debuginfo, p-cpe:/a:rocky:linux:php-ldap, p-cpe:/a:rocky:linux:php-ldap-debuginfo, p-cpe:/a:rocky:linux:php-xml-debuginfo, p-cpe:/a:rocky:linux:php-xmlrpc, p-cpe:/a:rocky:linux:php-xmlrpc-debuginfo, cpe:/o:rocky:linux:8, p-cpe:/a:rocky:linux:apcu-panel, p-cpe:/a:rocky:linux:libzip, p-cpe:/a:rocky:linux:libzip-debuginfo, p-cpe:/a:rocky:linux:libzip-debugsource, p-cpe:/a:rocky:linux:libzip-devel, p-cpe:/a:rocky:linux:libzip-tools, p-cpe:/a:rocky:linux:libzip-tools-debuginfo, p-cpe:/a:rocky:linux:php, p-cpe:/a:rocky:linux:php-bcmath, p-cpe:/a:rocky:linux:php-bcmath-debuginfo, p-cpe:/a:rocky:linux:php-cli, p-cpe:/a:rocky:linux:php-cli-debuginfo, p-cpe:/a:rocky:linux:php-common, p-cpe:/a:rocky:linux:php-common-debuginfo, p-cpe:/a:rocky:linux:php-dba, p-cpe:/a:rocky:linux:php-dba-debuginfo, p-cpe:/a:rocky:linux:php-dbg, p-cpe:/a:rocky:linux:php-mbstring, p-cpe:/a:rocky:linux:php-mbstring-debuginfo, p-cpe:/a:rocky:linux:php-mysqlnd, p-cpe:/a:rocky:linux:php-mysqlnd-debuginfo, p-cpe:/a:rocky:linux:php-odbc, p-cpe:/a:rocky:linux:php-odbc-debuginfo, p-cpe:/a:rocky:linux:php-opcache, p-cpe:/a:rocky:linux:php-opcache-debuginfo, p-cpe:/a:rocky:linux:php-pdo, p-cpe:/a:rocky:linux:php-pdo-debuginfo, p-cpe:/a:rocky:linux:php-pear, p-cpe:/a:rocky:linux:php-pecl-apcu, p-cpe:/a:rocky:linux:php-pecl-apcu-debuginfo, p-cpe:/a:rocky:linux:php-pecl-apcu-debugsource, p-cpe:/a:rocky:linux:php-pecl-apcu-devel, p-cpe:/a:rocky:linux:php-pecl-rrd, p-cpe:/a:rocky:linux:php-pecl-rrd-debuginfo, p-cpe:/a:rocky:linux:php-pecl-rrd-debugsource, p-cpe:/a:rocky:linux:php-pecl-xdebug, p-cpe:/a:rocky:linux:php-pecl-xdebug-debuginfo, p-cpe:/a:rocky:linux:php-pecl-xdebug-debugsource, p-cpe:/a:rocky:linux:php-pecl-zip, p-cpe:/a:rocky:linux:php-pecl-zip-debuginfo, p-cpe:/a:rocky:linux:php-pecl-zip-debugsource, p-cpe:/a:rocky:linux:php-pgsql, p-cpe:/a:rocky:linux:php-pgsql-debuginfo, p-cpe:/a:rocky:linux:php-process, p-cpe:/a:rocky:linux:php-process-debuginfo, p-cpe:/a:rocky:linux:php-snmp, p-cpe:/a:rocky:linux:php-snmp-debuginfo, p-cpe:/a:rocky:linux:php-soap, p-cpe:/a:rocky:linux:php-soap-debuginfo, p-cpe:/a:rocky:linux:php-xml

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/RockyLinux/release, Host/RockyLinux/rpm-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 11/8/2022

Vulnerability Publication Date: 7/21/2021

Reference Information

CVE: CVE-2021-21707, CVE-2021-21708, CVE-2021-32610

IAVA: 2021-A-0566-S