Ubuntu 16.04 ESM / 18.04 ESM / 20.04 ESM : Slurm vulnerabilities (USN-4781-1)

critical Nessus Plugin ID 183132

Synopsis

The remote Ubuntu host is missing one or more security updates.

Description

The remote Ubuntu 16.04 ESM / 18.04 ESM / 20.04 ESM host has packages installed that are affected by multiple vulnerabilities as referenced in the USN-4781-1 advisory.

- The _prolog_error function in slurmd/req.c in Slurm before 15.08.13, 16.x before 16.05.7, and 17.x before 17.02.0-pre4 has a vulnerability in how the slurmd daemon informs users of a Prolog failure on a compute node. That vulnerability could allow a user to assume control of an arbitrary file on the system. Any exploitation of this is dependent on the user being able to cause or anticipate the failure (non-zero return code) of a Prolog script that their job would run on. This issue affects all Slurm versions from 0.6.0 (September 2005) to present. Workarounds to prevent exploitation of this are to either disable your Prolog script, or modify it such that it always returns 0 (success) and adjust it to set the node as down using scontrol instead of relying on the slurmd to handle that automatically. If you do not have a Prolog set you are unaffected by this issue. (CVE-2016-10030)

- Insecure SPANK environment variable handling exists in SchedMD Slurm before 16.05.11, 17.x before 17.02.9, and 17.11.x before 17.11.0rc2, allowing privilege escalation to root during Prolog or Epilog execution.
(CVE-2017-15566)

- SchedMD Slurm before 17.02.10 and 17.11.x before 17.11.5 allows SQL Injection attacks against SlurmDBD.
(CVE-2018-7033)

- SchedMD Slurm before 17.02.11 and 17.1x.x before 17.11.7 mishandles user names (aka user_name fields) and group ids (aka gid fields). (CVE-2018-10995)

- SchedMD Slurm before 17.11.13 and 18.x before 18.08.5 mishandles 32-bit systems. (CVE-2019-6438)

- Slurm 19.05.x before 19.05.7 and 20.02.x before 20.02.3, in the rare case where Message Aggregation is enabled, allows Authentication Bypass via an Alternate Path or Channel. A race condition allows a user to launch a process as an arbitrary user. (CVE-2020-12693)

- Slurm before 19.05.8 and 20.x before 20.02.6 has an RPC Buffer Overflow in the PMIx MPI plugin.
(CVE-2020-27745)

- Slurm before 19.05.8 and 20.x before 20.02.6 exposes Sensitive Information to an Unauthorized Actor because xauth for X11 magic cookies is affected by a race condition in a read operation on the /proc filesystem. (CVE-2020-27746)

- SchedMD Slurm before 20.02.7 and 20.03.x through 20.11.x before 20.11.7 allows remote code execution as SlurmUser because use of a PrologSlurmctld or EpilogSlurmctld script leads to environment mishandling.
(CVE-2021-31215)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Update the affected packages.

See Also

https://ubuntu.com/security/notices/USN-4781-1

Plugin Details

Severity: Critical

ID: 183132

File Name: ubuntu_USN-4781-1.nasl

Version: 1.0

Type: local

Agent: unix

Published: 10/16/2023

Updated: 10/16/2023

Supported Sensors: Agentless Assessment, Frictionless Assessment Agent, Frictionless Assessment AWS, Frictionless Assessment Azure, Nessus Agent, Nessus

Risk Information

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: High

Base Score: 7.6

Temporal Score: 5.6

Vector: CVSS2#AV:N/AC:H/Au:N/C:C/I:C/A:C

CVSS Score Source: CVE-2016-10030

CVSS v3

Risk Factor: Critical

Base Score: 9.8

Temporal Score: 8.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

CVSS Score Source: CVE-2020-27745

Vulnerability Information

CPE: p-cpe:/a:canonical:ubuntu_linux:slurm-client-emulator, p-cpe:/a:canonical:ubuntu_linux:libslurm29, p-cpe:/a:canonical:ubuntu_linux:libslurmdb32, p-cpe:/a:canonical:ubuntu_linux:libslurmdb26, p-cpe:/a:canonical:ubuntu_linux:slurm-wlm-basic-plugins, p-cpe:/a:canonical:ubuntu_linux:libslurmdb29, p-cpe:/a:canonical:ubuntu_linux:libslurmdb-perl, p-cpe:/a:canonical:ubuntu_linux:slurm-wlm-torque, p-cpe:/a:canonical:ubuntu_linux:libpmi2-0-dev, p-cpe:/a:canonical:ubuntu_linux:libpam-slurm-adopt, p-cpe:/a:canonical:ubuntu_linux:slurm-wlm-emulator, p-cpe:/a:canonical:ubuntu_linux:libpam-slurm, cpe:/o:canonical:ubuntu_linux:16.04:-:esm, p-cpe:/a:canonical:ubuntu_linux:slurm-llnl-torque, p-cpe:/a:canonical:ubuntu_linux:libslurmdb-dev, p-cpe:/a:canonical:ubuntu_linux:slurmctld, p-cpe:/a:canonical:ubuntu_linux:libslurm-dev, p-cpe:/a:canonical:ubuntu_linux:slurmdbd, p-cpe:/a:canonical:ubuntu_linux:slurm-llnl, p-cpe:/a:canonical:ubuntu_linux:libpmi0-dev, p-cpe:/a:canonical:ubuntu_linux:libslurm-perl, p-cpe:/a:canonical:ubuntu_linux:slurm-wlm-basic-plugins-dev, cpe:/o:canonical:ubuntu_linux:18.04:-:esm, p-cpe:/a:canonical:ubuntu_linux:libslurm26, p-cpe:/a:canonical:ubuntu_linux:slurm-llnl-basic-plugins-dev, p-cpe:/a:canonical:ubuntu_linux:slurm-wlm, p-cpe:/a:canonical:ubuntu_linux:libpmi2-0, p-cpe:/a:canonical:ubuntu_linux:slurm-client, p-cpe:/a:canonical:ubuntu_linux:libslurm32, p-cpe:/a:canonical:ubuntu_linux:slurmd, p-cpe:/a:canonical:ubuntu_linux:sview, p-cpe:/a:canonical:ubuntu_linux:slurm-llnl-basic-plugins, p-cpe:/a:canonical:ubuntu_linux:slurm-llnl-slurmdbd, p-cpe:/a:canonical:ubuntu_linux:libslurm34, p-cpe:/a:canonical:ubuntu_linux:libpmi0, p-cpe:/a:canonical:ubuntu_linux:slurm-llnl-sview, cpe:/o:canonical:ubuntu_linux:20.04:-:esm

Required KB Items: Host/cpu, Host/Ubuntu, Host/Ubuntu/release, Host/Debian/dpkg-l

Exploit Ease: No known exploits are available

Patch Publication Date: 5/25/2022

Vulnerability Publication Date: 1/5/2017

Reference Information

CVE: CVE-2016-10030, CVE-2017-15566, CVE-2018-10995, CVE-2018-7033, CVE-2019-6438, CVE-2020-12693, CVE-2020-27745, CVE-2020-27746, CVE-2021-31215

USN: 4781-1