OpenSSL < 0.9.7m / 0.9.8e Buffer Overflow (deprecated)

Medium Nessus Plugin ID 17758


This plugin has been deprecated.


According to its banner, the remote server is running a version of OpenSSL that is earlier than 0.9.7m or 0.9.8e.

A remote attacker could trigger a one-byte buffer overflow. The real impact is unknown. Arbitrary code could be run but no functional exploit was published.

This plugin has been deprecated. Use openssl_0_9_8f.nasl (plugin ID 17760) instead.



See Also

Plugin Details

Severity: Medium

ID: 17758

File Name: openssl_0_9_7m_0_9_8e.nasl

Version: $Revision: 1.9 $

Type: remote

Family: Web Servers

Published: 2012/01/04

Modified: 2017/02/22

Dependencies: 57323

Risk Information

Risk Factor: Medium


Base Score: 6.8

Temporal Score: 5.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:openssl:openssl

Required KB Items: openssl/port

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2007/10/12

Vulnerability Publication Date: 2007/10/12

Reference Information

CVE: CVE-2007-5135

BID: 25831

OSVDB: 29262

CWE: 189